
Case Study 2: Piezoelectric Circular Plate 
 
 
PROBLEM - 3D Circular Plate, kp Mode, PZT4, D=50mm x h=1mm 
 
 
GOAL  
 
Evaluate the operation of a piezoelectric circular plate having electrodes in the top and bottom surfaces 
and polarized in the thickness mode. The operation is evaluated in the transversal (Radial) direction, i.e. 
kp mode. The size of the circular plate is 50mm diameter x 1mm thickness. The piezoelectric plate is 
made of PZT4 material. 
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Figure C2.1.  Menu sequence for creating a circle 

 
 

D = 50 mm 
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Material: PZT4 
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GEOMETRY/DRAWING 
 

1. Start GiD  
 
 
Start GID using the desktop icon. 
 
Note: This example will incorporate both the menu and icon options to begin and transition to the most 
straightforward method as the example progresses. Later examples will outline the process and allow the 
user to select the method they are most comfortable with. All new processes will explain both options 
when introduced. 
 
2. Create the 3D Model  
 
2.1 Create the circle/surface 
 
Alternative 1: Using the Drop Down menus. 
 

Geometry → Create → Object → Circle → Enter center point   → 0,0 → Enter → 
Enter Normal → Select then OK →  Enter Radius→ 25 → Enter  
 

This sequence is illustrated in Figure C2.2. 
 

 
 
                                             
 
 

 
Figure C2.2.  Menu sequence for creating a circle 

 
 
 



Alternative 2: Using the Icons 
 

To create the circle using the icons bar, Click  , the object icon drop menu will appear. Then click the 

circle icon . In the dialog box, enter the center for the circle (0,0) and press Enter. Then, enter a 
normal for the circle. In our case, choose Positive Z. Finally, enter the radius for the circle in the dialog 
box (25) and press Enter to finish the circle generation. This sequence is illustrated in Fig C2.3. 
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Figure C2.3.  Icon sequence for creating a circle. 

 
The circle line (in blue) has been created with the corresponding surface (in magenta color). In this case, 
to allow quadrilateral meshing in the center of the disc, it is required to create an additional surface in the 
center are of the disc. This will be done later on. Since two surfaces will be created, the first thing is to 
remove the surface created for the disc and then created the needed new surface in the center.  
 
2.2 Deleting the Surface  
 
Note: As indicated, this step is necessary before creating a quadrilateral element in the center for better 
meshing. Failure to delete this surface will cause issues later because of overlapping surfaces. 
 
Alternative 1: Delete Surface Using the Drop Down Menus 
 

Geometry → Delete → Surfaces → Select Circle Surface → ESC   
 
The process of deleting a surface using the drop down menu illustrated in Figure C2.4. 
 



 
 
                                             
 
 

Delete Surface 

Once selected 
click "ESC" 

Select the surface to Delete 
(it will change the color to 

red) 

The surface has 
been removed  

Figure C2.4.  (Left) Menu sequence for deleting a surface; (Right) Result after removing the surface. 
Only the circle line remains. 

 
Alternative 2: Delete Surface Using the Icons 
 

To remove the surface using the icons, Click . The delete drop menu will appear. Choose the surface 

icon, , to remove only the surface. Then, select Circle Surface to be removed. The surface will be 
highlighted in red. Press ESC to remove the surface. This sequence is shown in Figure C2.5. 
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Figure C2.5.  Icon sequence for deleting a surface 
 



2.3 Creating the center quadrilateral element for meshing of the center 
 
As indicated, to obtain a better mesh, a quadrilateral element will be created at the center of the circle. 
 
Alternative 1: Using the Drop Down Menus 
 

Geometry → Create → Straight line → Points (0,5) → Enter → Points (5,0) → Enter 
→ Points (0,-5) → Enter → Points (-5,0) → Enter → Points (0,5) → Enter →Join → 
ESC.  

 
This sequence is shown in Figure C2.6. 
 

 
 
                                             
 
 

Introduce the coordinates of 
the new surface 

 
Figure C2.6.  Menu sequence for creating the quadrilateral 

 
Alternative 2: Using the Icons 
 

Click   → Points (0,5) → Enter → Points (5,0) → Enter → Points (0,-5) → Enter → Points (-5,0) → 
Enter → Points (0,5) → Enter →Join → ESC. This sequence is shown in Figure C2.7. 
 

 
 
                                             
 
 

 
Figure C2.7.  Icon sequence for creating the quadrilateral 



2.4 Dividing the circle 
 
The corners of the quadrilateral (square) need to be connected to the circle. The coordinates of the square 
were created to lie on the axis of the circle. Dividing the circle using the divide function will place a point 
on the each axis. This sequence is shown in Figure C2.8. The result is shown in Figure C2.9. 
 
Alternative 1: Using the Drop Down Menus 
 

Click Geometry  → Edit → Divide → Lines → Num divisions → Enter (4) → OK 
 
This sequence can be seen in Figure C2.8. 
 
Alternative 2: Using the Icons 
 

Click . Then enter the number of divisions. Enter (4). Press OK to finish. This sequence can be seen in 
Figure C2.8. 
 

 

 
Figure C2.8.  Sequence for dividing a line using drop down menus (left) and icons (right) 

 

 
Figure C2.9.  The divided circle with a quadrilateral at the center 

 



2.5 Creating Connecting lines 
 
The connecting lines need to be created from the corners of the quadrilateral to the points created on the 
circle. Both the menu and icon sequence are shown in the top panels of Figure C2.10. The first line and 
the final geometry are shown in the bottom panels of Figure C2.10. 
 
Alternative 1: Using the Drop Down Menus 
 

Click Geometry  → Create → Straight line → Control-A → □▪  → Select 1st 2 - points 

→ ESC → Select 2nd  2 - points → ESC→ Select 3rd  2 - points → ESC → Select 4th  2 
- points → ESC → ESC  

 
This sequence can be seen in Figure C2.10 -top left. 
 
Alternative 2: Using the Icons 
 

Click  → Control-A → □▪  → Select 1st 2 - points → ESC → Select 2nd  2 - points → ESC→ Select 3rd  

2 - points → ESC → Select 4th  2 - points → ESC → ESC.  See Figure C2.10 top right. 
 

 Top Drop Menu Vertical Icons Bar 

 
Figure C2.10.  Connecting the quadrilateral to the circle using the menus 



2.6 Create surface 
 
Alternative 1: Using the Drop Down Menus 
 
GID will create surfaces automatically based on the information entered.  
 

Click  Geometry  → Create → NURBS surface → Automatic → Enter (4) → OK 
 
This sequence is shown in Figure C2.11. The resultant surfaces are shown in Figure C2.12. 
 

       
Figure C2.11.  Menu sequence for creating surfaces 

 
Alternative 2: Using the Icons 
 
The icon option requires that the bounding lines of the surface be selected to create the surface. This 
allows the user control over how the surfaces are created. Select the bounding entities that will form the 
edges of the surface, when finished with that surface click ESC. The cursor will remain for the creation of 
additional surfaces. The resultant surfaces are shown in Figure C2.12. 

Click    →(□▪  ) → Select the bounding lines of the first surface  → ESC → Select the 2nd set of 

bounding lines for the next surface → ESC → Repeat the same for the rest of surfaces →  ESC to quit. 

 

 
Figure C2.12.  Geometry after the creation of surfaces 



2.7 Create Volumes Using Copy and Create 
 
Alternative 1: Using the Drop Down Menus 
 

Utilities → Copy → Surfaces → Translate → Enter first point  → 0,0,0 → Enter 
second point → 0,0,1.0 → Do Extrude: Volumes → Select → Finish 

 
In Case 1 the volume was created directly when the 2D geometry was extruded into 3D. This is usually 
the fastest way. This example will use a second method that creates the 3D geometry then the volumes to 
show an alternative method of volume creation.   
 
Click Utilities →  Copy.   
                                         
In the Copy menu, select Entities type: Surfaces and Translation for the type of Transformation. For this 
example, the First Point coordinate is the default value, i.e (0,0,0), the Second Point is the thickness of the 
plate, in this example 1mm, i.e. the Second Point should be (0,0,1.0). Check the box - Do Extrude 
Surfaces, Maintain Layers, and Multiple copies is 1. This will copy the circular surface in the positive 
Z direction and extrude the cylinder at the same time. It will not create the volume. This sequence is 
illustrated in Figure C2.13. 
 

                  
Figure C2.13. Settings for the Copy Control Panel 

 
To complete the copy operation Click Select in the Copy menu. The cursor will change to a large square 
with a small square inside (□▪ ). Select the surfaces of the Circle and quadrilateral. The color will change 
from magenta to red indicating that GiD has accepted the selection. Click Finish to complete the copy. 
GiD translated the surface and extruded the cylinder to create a solid model and the corresponding 
surfaces. This resulting geometry is illustrated  Figure C2.14. 
 



 
Figure C2.14. Circle geometry and surfaces copie/extruded 

 
The volumes can be added quickly using the menus. The Warning panel confirms the creation of the 
volumes. This sequence is illustrated in Figure C2.15. Figure C2.17 illustrates the disk after all of the 
volumes have been created. 
 

Click Geometry → Create → Volume → Automatic 6-sided volumes → Warning 
panel with confirmation appears → OK 

 

 
 

 
Figure C2.15. Settings for the Copy Control Panel 

 
Alternative 2: Using the Icons 
 
The same process can be accomplished with the icons, however, it requires that all of the bounding 
surfaces for each volume be selected. 



 

Click   → (□▪ ) → Select surfaces that bound the proposed volume → Esc to create the volume → Esc 
to quit (When all volumes have been created)  
 
See selection of the quadrilateral and the creation of the volume in Figure C2.16. Figure C2.17 illustrates 
the disk after all of the volumes have been created. 
 

        
Figure C2.16. Selection and creation of Volumes 

 

 
Figure C2.17. Complete Disk 

 
Note: If all bounding surfaces are not selected a warning panel appears and the volume is not created. See 
Figure C2.18. for an example of the warning panel. 
 

 
Figure C2.18. Volume creation error Information window 

 



MATERIALS AND CONDITIONS 
 
3. Materials Assignment 
 
The next step is to assign the material and boundary conditions necessary for the simulation. Begin by 
activating ATILA in the Problem type.  
 

Click Data → Problem type → Atila → 3.0.21.  
 
Note:  Other compatible versions of Atila may be present, for this example we will use 3.0.21. See Figure 
C2.19. 
 

 
Figure C2.19. Starting ATILA 3.0.21 

 
The header will now show the version of Atila being used and the menu and Icons will be available for 
use, as shown in Figure C2.20. 
 

 
Figure C2.20. ATILA 3.0.21 Menus and Icons 

 
Alternative 1: Using the drop down menu 
 

Click Data → Materials → Piezoelectric → Control Panel appears → Select PZT4 
→ Assign by Volumes → Select Volumes → Finish  

 
This sequence is illustrated in Figure C2.21at the top left panel. 
 



Alternative 2: Using the Icons 

Click  → Control Panel appears → Select PZT4 → Assign by Volumes → Select Volumes → Finish. 
This is illustrated in Figure C2.21 at the top right panel. 
 
 Top Drop Menu Vertical Icons Bar 

 
Figure C2.21. Piezoelectric Material Selection 

 
Select all the volumes of the Disk, they will change from cyan to red indicating GiD has accepted the 
selection. Click Finish or ESC to complete the operation.  
 
Click Draw → PZT4 to confirm the material has been added. Click Finish or ESC to quit. See Figure 
C2.22. 
 

 

 
Figure C2.22. Piezoelectric Material Selection 

 
 



4. Boundary Conditions Assignment 
 
Assignment of Boundary conditions is necessary for the simulation. These are the constraints and 
parameters that will govern how ATILA processes the simulation. This example will cover using the 
menus and/or the icons.  
 
Alternative 1: Using the top drop menus 
 
Click Data → Conditions as shown in Figure C2.23 left panel.  The conditions panel appears as seen in 
Figure C2.23 bottom panel. 
 
Alternative 2: Using the Icons 

Click ( ) as shown in Figure C2.23, right panel.  The conditions panel appears as seen in Figure C2.23 
bottom panel. 
 

 Top Drop Menu Vertical Icons Bar 

 
Figure C2.23. Boundary Conditions Assignment 

 
 
4.2 ASSIGN ELECTRICAL POTENTIAL BOUNDARY CONDITIONS 
 

Click   → Electrical Potential  → Forced → Enter 1.0 → Assign → Select Surface 
→ Finish or Esc. 

 



Select Surfaces  icon on the top panel and Electrical Potential for the condition. Enter (1.0) in the 
space provided for the value of the Forced potential. This value is in Volts. After setting the voltage, 
click Assign and select the top surface of the plate. It will turn red indicating acceptance of the selection. 
Click Finish to complete. See Figure C1.24. 

 

     
Figure C1.24. Boundary Conditions Control Panel 

 
Assign Ground Potential (-) 
 
 

Click   → Electrical Potential  → Ground → Enter 0.0 → Assign → Select 
Surface → Select the bottom surface of the bar → Finish or Esc. 

 
Repeat the same process to assign the Ground electrode. Click Ground → Assign, select the bottom 
surface of the plate. The surface will turn red to signify acceptance of the selection. Click Finish to 
complete. Confirm the Electrical Potential assignment by clicking Draw → Colors. See the result in 
Figure C.25. Click Finish to quit.   
 

 
Figure C2.25.  Electrical Potential assignment confirmation 

 



4.3 ASSIGN POLARIZATION BOUNDARY CONDITIONS 
 
It is necessary to assign the volume polarization of the piezoelectric material. This will determine the 
direction of the movement of the material in response to the applied voltage. 

Click the volume icon ( ) on the top of the control panel, then select Polarization from the list. In this 
example the default, Cartesian, is selected. Click Define. The Local Axis naming panel will appear as 
shown in Figure C1.26.  
 
It is necessary to name the “Local Axis system”, for this example use P1. (Note: this can be any name that 
makes sense or best describes this axis for the particular application.) Enter P1 and press Enter or click 
OK.   
 

             
Figure C2.26. Boundary Conditions Control Panel - Polarization 

 
The orientation dialog window will appear giving two options for defining the axis location and direction. 
This example will use the X and Angle option. See Figure C1.27. 
 

 
Figure C2.27. Local axis dialog window 

 
Note: ATILA Cartesian polarization follows the “Z” Local direction.  
 
 
 
 



There are two options to define the local axis: 
 
Alternative 1: Graphical Option 
 
Click the X and Angle button and the cursor will change to a plus (+). You will need to select 2 points 
along the “X” axis to set the “X” direction. Right click in the graphics window and click Contextual → 
Join Ctrl-A as shown in Figure C1.28. The cursor will change to a square with the smaller square inside 
(□▪ ). This change can also be accomplished by holding the Control key and pressing A.  
 

Click  X and Angle → (+)  → Join Ctrl-a → 1st point → Join Ctrl-a → 2nd point → 
Select Angle→ Assign volumes → Finish or ESC. 

 

 
Figure C2.28. Onscreen menu 

 
The Join function allows you to select points already created and snap to them. Select the first corner, 
reselect Join Ctrl-A, select the top corner. See these selections in Figure C2.29. left panel. 
 
A moveable axis will appear, move the mouse to orient it in the desired direction, for this example match 
the graphic “Z” axis or 180 degrees.  The angle will appear next to the cursor, when it is at “180” click the 
Right Mouse Button to select. See illustration in Figure C2.29 left panel, red circle. The polarization axis 
is shown in Figure C2.29. right panel. 
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Figure C2.29. Creation of Local axis 



Alternative 2: Coordinate Entry Option 
 

Click  X and Angle → Enter axis center  → Enter  → Enter point in positive X 
direction → Enter → Enter Angle for Y → Assign volumes → Finish or ESC. 

 
Click the X and Angle button and the cursor will change to a plus (+). Move the cursor to the Command 
Line, enter the coordinates for the Center of the local axis, Enter. Enter the coordinates for a point in the 
positive X direction Enter. Enter the Angle to define the Y axis (This is relative to the graphic axis). 
These steps are shown in Figure C2.30. The Polarization axis will appear as shown in Figure C2.29. right 
panel. 
 

         
Figure C2.30. Boundary Conditions Control Panel 

 
To confirm the assignment of polarization click Draw → All conditions → Include local axis.  The 
process and results are shown in Figure C2.31.  
 

        
Figure C2.31. Confirmation of Polariation  

 
Note: All of the conditions will be shown in red. See center panel of Figure C2.31. 
 
Select Finish or ESC to quit Draw. 
 
 
 
 
 
 
 
 



MESH 
 
5. Meshing the model 
 
The geometry is created, the material assigned, and the conditions assigned, the next step is to mesh the 
model. Meshing divides the part into geometric components that the software uses to calculate the stress, 
deformation, etc to create the outputs used for analysis. There are several options to generate the mesh. 
Here we provide two examples. More details can be found in GiD help. 
 
5.1 SETTING MESH TYPE 
 
The default mesh type in GID is Normal, this example will use Quadratic.  
Note: Changes made in the preferences will remain until changed or the preferences reset to the default 
settings. 
 
Alternative 1: Change mesh type Menu option 
 

Click Utilities → Preferences → Preference Control Panel appears → Meshing → 
Quadratic → Accept → Close 

 
The menu is shown in Figure C2.32, the Preference Control Panel is shown in Figure C2.33. 
 

 
Figure C2.32. Menu selection for Preferences 

 
Alternative 2: Change mesh type Hot Key option 
 

CTRL + P → Preference Control Panel appears → Meshing → Quadratic → Accept → Close 
 
The Preference Control Panel is shown in Figure C2.33. 
 



 
Figure C2.33. Preferences Control Panel  

 
5.2 STRUCTURED MESH 
 
To setup the structured mesh follow these steps as illustrated in Figure C2.34.  
 

Click  Mesh → Structured → Volumes → Assign number of cells 
 

 
Figure C2.34. Creating a Structured Mesh 

 
The cursor will change to a square with the small square in the center (□▪ ), select the volume you want to 
mesh. Press ESC. (Note: This process will be followed for each volume to be meshed if there is more 
than one. The mesh of adjacent volumes must be the same size.). This example will mesh all of the 
volumes with the same size elements. The control panel shown in Figure C2.35., left panel, will appear. 
Enter the number of divisions for a line. Click Assign.   
 



 

Figure C2.35. Assigning number of divisions. Select the 6 divisions for the radial lines and the 
circunference lines.  

 
The cursor will change (□▪ ) to allow the selection of the lines for that number of divisions. When the lines 
are selected they will turn red indicating acceptance. (Note: Depending on the method of construction 
lines that are opposite one another will all be selected together, this is the case in this example. See Figure 
C2.36. right panel) When finished selecting the lines for that number of divisions press ESC. The Control 
Panel will reappear with the option to enter a different value as shown in Figure C2.36., left panel. The 
selection process is the same as used in the previous step. When all of the lines have been assigned a 
number of divisions press ESC, then ESC again to quit. 
 

    
Figure C2.36. Assigning number of divisions for the plate thickness. 

 
Press CTRL + G, the Mesh Generation control panel below will appear. Click Get meshing parameters 
from model and click OK, see Figure C2.37. left panel. The mesh will be generated, select View mesh to 
see the mesh as illustrated in Figure C2.38 panel. 
 

    
Figure C2.37. Meshing the geometry 

 



 
Figure C2.38. Meshing the geometry. Left: using hexahedra elements; Right: using tetahedra elements. 

 
Note: In GiD 10, the default element type is hexahedra, so the resulting meshing will be the one shown in 
Figure C2.38 left.  
 
Howeever, in GiD 11, the default element type is tetahedra and the results of using CTR + G will be as 
shown in Figure C2.38 right. Hexahedra elements uses less numbers of nodes than when using tetaedra 
elements. To select hexahedra as the element for the mesh, select Mesh → Element Type → Hexahedra. 
This can be observed in Figure C2.39 
 

 
Figure C2.39. Selection of Hexahedra elements fot the meshing.  

 



CALCULATE 
 
6. Calculations 
 
The model has been created, the material and the boundary conditions assigned, and the geometry 
Meshed, the next step is to assign the Problem Data. The Problem Data menu assigns the rules for the 
simulation. These rules determine the type of simulation, the number of steps, etc that are to be run to 
generate the data for analysis.   
 
6.1 HARMONIC CALCULATION 
 
STEP 1: SELECT HARMONIC ANALYSIS FROM PROBLEM DATA 
 

Click Data →Problem Data, the Control Panel will appear. (alternatively, click ) 
Click Geometry → 3D. 
Click Analysis →Harmonic.  
Click Include Losses →Write strain →Write stress →Accept. The lower left corner of the control 
panel will flash the message “Problem Data modified”.  See these steps in  Figure C2.40. 
 

    
Figure C2.40. Assign Problem Data 

 
STEP 2: ENTER THE FREQUENCY RANGE TO PERFORM THE HARMONIC ANALYSIS 
 

Click Data →Interval Data. The Interval Data Control Panel will appear. (alternatively, click ) 
Click TYPE → LINEAR DISTRIBUTION. 
Enter the Minimum and Maximum frequencies and the number of frequencies to be tested. (Note: 
More points tested will give a smoother Admittance/Impedance graph and more accurate results. 
However the calculation time will increase correspondingly.) Click Accept when finished, the lower left 
corner of the control panel will flash the message Interval Data modified. The sequence is shown in 
Figure C2.41. 
 
                                       



     
Figure C2.41. Assign Interval Data 

 
At this point, all of the necessary information to perform an harmonic calculation has been entered. The 
next step is to run the calculation/simulation. 
  
STEP 3: START THE CALCULATION 
 
Click Calculate → Calculate as shown in Figure C2.42 left panel. The calculation dialog box will appear 
briefly letting you know the calculation has started. See Figure C2.42 center panel. 
 
Note: The progress can be monitored by clicking Calculate, then View Process info… This will open the 
window displaying the calculation processes as they are proceeding. When the calculations are complete 
the Process Info panel will appear. Click Post-process to open the postprocessor and view the results of 
the simulation. See Figure C2.42 right panel. 
 
 

    
    

 
Figure C2.42. Calculation Panels 

 
 



RESULTS 
 
7. Post-Process/View Results 
 
The post-process mode will appear similar to the preprocess mode with the addition of several new 

commands and icons. See window in Figure C2.43. On the left, select the Display Style icon  to 

change the style of visualization. In Figure C2.43, the display style  has been selected to activate the 
mesh. 
 

 
Figure C2.43. Post-Processor Window 

 
 
TIP: To enter to the postprocessor mode after exiting or for a calculation that has been run previously, 

open the file and click ( ). This will load the data and open the postprocessor window.  
 
7.1 ADMITTANCE GRAPH 
 

Click ( ) → Admittance: Magnitude Results → Select Admittance → Select View Graph. 
 
The Admittance & Impedance Results control panel will appear, as seen in Figure C2.43. 
 

 
Figure C2.43. Admittance/Impedance Control Panel 

 
Select the desired characteristic, Admittance: Magnitude, then select  View Graph. The Admittance 
magnitude graph will appear as seen in Figure C2.44. 



The Admittance magnitude graph will appear, see Figure C1.36. left panel. Other options available 
include Phase, Conductance, Susceptance and Circle admittance and associated values for the Impedance 
as illustrated in Figure C2.44. To get the exact coordinates of a point on the graph right click in the 
graphics window. The contextual menu will appear, select Label →Select → Res, as seen in Figure 
C2.44 for the maximum value of the admittance plot. 
 

 
Figure C2.44. Admittance Magnitude Graph 

 
The values of the graph can be exported to an Excel file for later analysis. In order to do so, select the 
ATILA menu and then Open shell. The file named with the problem_name.adm.csv includes the 
admittance data. The file named problem_name.imp.csv includes the impedance data. This is illustrated 
in Figure C2.45. 
 

   
Figure C2.45. The impedance and admittance data can be open in Excel format. 

 



A clearer picture of the admittance graph can be seen by transforming the “Y” scale of the graph to a log 
scale. To make this change click Options → Graphs → Y axis → Set Logarithmic Scale. The 
confirmation window will appear, click Yes. See Figure C2.46. for this process. 
 

    
Figure C2.46. Converting Y axis to Log10 Scale 

 
The graph now displays the result with a log scale. The resonant peaks can be seen more clearly as shown 
in Figure C2.47. 
 

 
Figure C2.47. Admittance Graph 

 

To remove the admittance graphs select the clear graphs icon ( ).  
 



7.2 VIEW RESULTS - DEFORMED SHAPE 
 
In addition to generate the admittance and impedance values, ATILA provides different type of results for 
the harmonic simulation. Select View results or select the icon vertical menu to select one of the 
visualization modes for the results as shown in Figure C.2.48. 
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Figure C2.48. View Results display options. 

 
For an harmonic simulation, the results are provided for each frequency. Let's select the frequency of 
46000 Hz corresponding to the maximum of admittance and let's display the Total displacement using the 
Contour Fill visualization.  
 
First select the desired frequency using View Results  → Default Analysis/Step. Then, it is possible to 
select the Imag Part, the Magnitude or the Real Part for the results. We will choose Magnitude for this 
example and then we pick up 46000 as shown in Figure C2.49. 
 

 
Figure C2.49. Selection of the specific frequency to show the results. 



Next, we select Contour Fill → Displacement  → Total Displacement as shown in Figure C.2.50. 
  

 
Figure C2.50. Selection of Total Displacement using Contour Fill visualization option. 

 
This will retrieve the total displacement in the disc, which in this case correspond to the radial 
vibration for the first resonance mode as shown in  
 

 
Figure C2.51. Total Displacement in the disc for the frequency of 46000Hz.  

 
7.3 ANIMATION 
 
To run the animation follow the steps below. 
 
1. Select the frequency to view: 
Click View Results → Default Analysis/Step → Harmonic-Magnitude → Value (for instance 46000 
Hz) 
 
2. Load the animation: 

Click  ( )→Atila Animation window appears → Click OK 
 
The Atila Animation panel illustrated in Figure C2.52 confirms the frequency selected and activates the 
loading process for the animation. 
 

 
Figure C2.52. Animation panel. 



Inmediatly after this, the ATILA Animate window will appear. This window allows the user to play the 
movie, save the movie, etc. The ATILA Animate window is shown in Figure C2.53. 
 

 
Figure C2.53. ATILA Animate window. 

 
 
3. Select Deformed shape 

Once the Animation Control panel has appeared, click ( )  and select a deformation magnitude factor to 
show the deformed shape. The factor can be adjusted progressively to obtain the best representation of the 
results. 
 
4. Run the animation 

Click ( ) to run the animation, the panels in Figure C2.54. illustrate the animation results at the 
maximum and minimum harmonic positions. As explained in Case 1 the animation can be stopped at any 

point by clicking ( ) and stepped through each modal point by clicking  ( ) or moving the ( ). 
 

   
Figure C2.54. Different steps observed during the animation. 

 
 



5. Add visualization options to show specific results:  
 
EXAMPLE: Total Displacement 
 
The animation can be stopped and other conditions added to the visualization, such as the displacement. 
Note: To add or change the visualization the animation must be stopped and restarted after the changes 
are made. In this example the Total-Displacement will be displayed in the animation.  
 
Alternative 1: View Total Displacement using the menus 
 
Click View Results →Contour Fill → Displacement →X-Displacement 
 
Alternative 2: View X-Displacement using the icons 

Click  ( )→ Displacement → X-displacement 
 

 OR   
Figure C2.55. Steps to view X-Displacement 

 
The average displacement is shown in the lower right corner of the graphics window, the value is keyed 
to the corresponding color on the part as illustrated below in Figure C2.56. 
 

 
Figure C2.56. Animation of the total displacement for 46,000 Hz 

 
 
 
 
 



EXAMPLE: Stress Sxy 
 
Alternative 1: View Stress Sxy using the menus 
 
Click View Results → Contour Fill → Stress → Sxy 
 
Alternative 2: View Stress Sxy using the icons 
 

Click (  )→ Stress → Sxy  
 
 

    OR  
Figure C2.57. Steps to visualize Stress on Part 

 
Figure C2.58. illustrates the results of stress visualization as seen in Atila/GID 
 

    
Figure C2.58. Animation of the Sxy for 46,000 Hz. 

 


